
 
 

ApertureToFileMaker 
 

ApertureToFileMaker is an Aperture plug-in that automates the process of 

exporting images and meta-data from Aperture into FileMaker. 

Step 1 – Install ApertureToFileMaker and Configure Your 

Database To Use JDBC Sharing 

Quit both FileMaker Pro and Aperture. Double click the ApertureToFileMaker 

installer and follow the on screen prompts. 

To use ApertureToFileMaker your FileMaker database needs to be configured to 

use JDBC Sharing. To enable JDBC sharing follow the set of instructions below: 

 

1) Open or create a FileMaker Pro database that you have Full Access to. 

2) From the FileMaker Pro menu select  Sharing > ODBC/JDBC… 

3) Turn On ODBC/JDBC Sharing. 

4) Select the FileMaker database for export and under ODBC/JDBC access 
to file check the All Users option.  

5) Click OK. Leave the database open and go to Step 2, below. 

 

Step 2 – Export Images and Meta-data 
 
To keep the export process simple and streamlined you re presented with pre-

built options that can be customized. These settings can be saved for future use 

to make workflows as fast as possible. Follow the directions below to begin the 

export process: 

 

1) Launch Aperture and select the images you would like to export. 

2) From the File menu select Export > FileMaker. 

3) Click Add to specify a FileMaker database for export. 

4) In the Database field, enter the name of the FileMaker database. Do not 
include the .fp7 extension in the file name. 

5) In the Account Name and Password fields, enter the account name and 



password for an account that has access to the file via JDBC (If you re 

using the sample database enter "Admin" as the account name and leave 

the password field blank). Click OK. These settings are now stored. 

6) In the Version Preset pop-up menu select the image type and size to 

export. 

� Selecting Edit… from the pop-up menu will allow you to customize 

your own presets. 

� Customized presets can be saved and will appear in the pop-up 

menu for later use. You can add and remove presets using the + 

and - buttons at the bottom of the window. 

7) In the Export Name Format pop-up menu select a name format for the 

exported images or create your own by selecting Edit…. 

� You can store and remove export name format presets for later use 

as in Step 6. 

8) Click Export. Select or create the folder where you would like the images 

to be stored and click Export. 

� Images are stored as a reference (FileMaker Pro doesn't import the 

image file, it keeps track of where it is on your Mac).  

� Best Practice: create a folder in the same location as your 

FileMaker database and store your images there. Anytime you 

move the database move the images folder along with it. 

9) Your images and associated meta-data are now located within your 

FileMaker database in a table called Aperture_Photo. 

 

Step 3 – View Records Within Your FileMaker Database 
 

You now have your images and their associated metadata within your FileMaker 

database, but how do you view it?  Below is a step-by-step guide on how to 

create a layout in your database to view the Aperture images and metadata 

 

1) Open your existing FileMaker Pro database.  

2) From the View menu select Layout mode. 

3) From the Layouts menu select New Layout/Report…. 

4) Enter a descriptive name for the layout. 

5) In the Show records from pop-up menu, select the Aperture_Photo table.  

6) For Select a layout type choose “Standard form” then click Next. 

7) In the Specify Fields window click Move All then click Next. 

8) Select a theme in the Layout themes list then click Finish. 

9) You now have a layout showing all your exported Aperture images and 

metadata. From the View menu select Browse Mode to view the 

individual records. 

 



System Requirements, Troubleshooting and FAQ 

 
System Requirements 

Aperture 1.5 

FileMaker Pro 8 - 8.5 or FileMaker Pro 8 – 8.5 Advanced 

 

Troubleshooting 

Connection Error: 

� If you added .fp7 after the database name while adding a database to the 

FileMaker Databases list remove the .fp7 extension and try again.  The 

.fp7 extension isn t needed in the Database field. 

� The ApertureToFileMaker plug-in checks the connection to the selected 

FileMaker database immediately after clicking on it. If you receive an error 

here make sure your database is open and accessible via JDBC as 

described in Step 1. 

� You must go through the JDBC sharing setup described in Step 1 for 

each database you wish to export to. 

� If everything is set up properly, verify that the account you're using to 

log into the database has access to JDBC sharing for that particular 

file. For more information on Accounts, privilege sets and extended 
privileges see Chapter 5 of the FileMaker Pro Users Guide, below. 
http://www.filemaker.com/downloads/pdf/fmp85_users_guide.pdf 

 

File Exports are Slow: 

� Performance can be increased dramatically by hiding the FileMaker Pro 

application or by minimizing the FileMaker database to the Dock. 

� Please keep in mind large exports with high-resolution images may take 

some time to reformat and copy. 

 

File Cannot be Found: 

� This error is displayed in place of images in the FileMaker database if the 

exported images folder has been moved, renamed or deleted. Move the 

images folder back to it s original location or revert the name to it s original 

one. 

 

Missing Fields: 

� If you delete a field in the Aperture_Photo Table, the plug-in will not 

replace the field during any subsequent export. You'll have to replace the 

missing field manually. 

� If a field is missing from a layout you can add it by switching to Layout 

Mode and from the Insert menu selecting Field… as long as it s not 

deleted from the table. 

 

Known Issues: 



� The Hostname field in the database setup window is not editable. At this 

time exporting to remote databases is not supported. 

� Some types of meta-data may not be exported to the FileMaker database. 

 

Frequently Asked Questions 

1) Why do errors occur while exporting my images? 

There are various reasons for this kind of error. One likely cause is if you 

have changed the database schema of the Aperture_Photo table within 

FileMaker. Changing the field name, type or other field options will usually 

cause the plug-in to fail. Likewise, removing a column will cause the plug-

in to fail. However, adding additional columns should not be a problem. To 

confirm that the plug-in is failing because of a bad database schema, see 

if exporting your photos to a newly created FileMaker database works. 

 

Strange data in a given metadata field can also cause the plug-in to fail. If 

some photos are able to export successfully, but others fail, this could be 

the reason.  

 

2) Is there an example FileMaker database available? 

Yes, an example database is included on the installation dmg. 

  

3) Can I export to a database hosted on a FileMaker Server? 

No, not at this time. 

 

4) Can I create the database locally and host the files on a server? 
Yes, but this is an unsupported configuration at this time that will require 

file sharing and FileMaker development experience. 

 

5) If I create an images database, who will be able to open it? 

All users accessing this file will need their own licensed copy of FileMaker 

Pro. 

 

6) What metadata will ApertureToFileMaker export? 

Below is a listing all the metadata that ApertureToFileMaker exports. 
 

Custom Properties: 

Aperture Key FileMaker DB Column Name 

cameraTimeZoneName camera_timezone_name 

pictureTimeZoneName picture_timezone_name 

 



EXIF Properties: 

Aperture Key FileMaker DB Column Name 

Altitude exif_altitude 

ApertureValue exif_aperture_value 

Artist exif_artist 

BrightnessValue exif_brightness_value 

CameraSerialNumber exif_camera_serial_number 

CaptureDayOfMonth exif_capture_day_of_month 

CaptureDayOfWeek exif_capture_day_of_week 

CaptureHourOfDay exif_capture_hour_of_day 

CaptureMonthOfYear exif_capture_month_of_year 

CaptureYear exif_capture_year 

ColorModel exif_color_model 

ColorSpace exif_color_space 

Contrast exif_contrast 

Depth exif_depth 

DNGBackwardVersion exif_dng_backward_version 

DNGVersion exif_dng_version 

ExifVersion exif_exif_version 

ExposureBiasValue exif_exposure_bias_value 

ExposureMode exif_exposure_mode 

ExposureProgram exif_exposure_program 

Firmware exif_firmware 

Flash exif_flash 

FlashExposureComp exif_flash_exposure_comp 

FlashPixVersion exif_flash_pix_version 

FocalLength exif_focal_length 

FocalLenIn35mmFilm exif_focal_len_in_35mm_film 

FocusMode exif_focus_mode 

GPSVersion exif_gps_version 

ImageDate exif_image_date 

ImageFileName exif_image_file_name 

ISOSpeedRating exif_iso_speed_rating 

Latitude exif_latitude 

LensMaxMM exif_lens_max_mm 

LensMinMM exif_lens_min_mm 

Longitude exif_longitude 

Make exif_make 

MapDatum exif_map_datum 

MaxApertureValue exif_max_aperture_value 

MeasuredEV exif_measured_ev 

MeteringMode exif_metering_mode 

Model exif_model 

NikonFlashSet exif_nikon_flash_set 



NikonFlashSetting exif_nikon_flash_setting 

NikonFocusMode exif_nikon_focus_mode 

NikonImageSharpening exif_nikon_image_sharpening 

NikonQuality exif_nikon_quality 

NikonSharpenMode exif_nikon_sharpen_mode 

NikonWhiteBalanceMode exif_nikon_white_balance_mode 

OwnerName exif_owner_name 

PixelHeight exif_pixel_height 

PixelWidth exif_pixel_width 

ProfileName exif_profile_name 

ProgramVersion exif_program_version 

Saturation exif_saturation 

SceneCaptureType exif_scene_capture_type 

Sharpness exif_sharpness 

ShootingMode exif_shooting_mode 

ShutterSpeed exif_shutter_speed 

Software exif_software 

SubjectDistance exif_subject_distance 

SubsecondTime exif_subsecond_time 

WhiteBalance exif_white_balance 

WhiteBalanceIndex exif_white_balance_index 

 

IPTC Properties: 

Aperture Key FileMaker DB Column Name 

ActionAdvised iptc_action_advised 

AudioDuration iptc_audio_duration 

AudioOutcue iptc_audio_outcue 

AudioSamplingRate iptc_audio_sampling_rate 

AudioSamplingRes iptc_audio_sampling_res 

AudioType iptc_audio_type 

Byline iptc_byline 

BylineTitle iptc_byline_title 

Caption/Abstract iptc_caption_abstract 

Category iptc_category 

City iptc_city 

Contact iptc_contact 

ContentLocationCode iptc_content_location_code 

ContentLocationName iptc_content_location_name 

CopyrightNotice iptc_copyright_notice 

Country/PrimaryLocationCode iptc_country_primary_location_code 

Country/PrimaryLocationName iptc_country_primary_location_name 

Credit iptc_credit 

DateCreated iptc_date_created 

DigitalCreationDate iptc_digital_creation_date 



DigitalCreationTime iptc_digital_creation_time 

EditStatus iptc_edit_status 

EditorialUpdate iptc_editorial_update 

ExpirationDate iptc_expiration_date 

ExpirationTime iptc_expiration_time 

FixtureIdentifier iptc_fixture_identifier 

Headline iptc_headline 

ImageOrientation iptc_image_orientation 

ImageType iptc_image_type 

Keywords iptc_keywords 

LanguageIdentifier iptc_language_identifier 

ObjectAttributeReference iptc_object_attribute_reference 

ObjectCycle iptc_object_cycle 

ObjectName iptc_object_name 

ObjectTypeReference iptc_object_type_reference 

OriginalTransmissionReference iptc_original_transmission_reference 

OriginatingProgram iptc_originating_program 

ProgramVersion iptc_program_version 

Province/State iptc_province_state 

ReferenceDate iptc_reference_date 

ReferenceNumber iptc_reference_number 

ReferenceService iptc_reference_service 

ReleaseDate iptc_release_date 

ReleaseTime iptc_release_time 

Source iptc_source 

SpecialInstructions iptc_special_instructions 

SubLocation iptc_sub_location 

SubjectReference iptc_subject_reference 

SupplementalCategory iptc_supplemental_category 

TimeCreated iptc_time_created 

Urgency iptc_urgency 

Writer/Editor iptc_writer_editor 

 

Aperture Properties: 

Aperture Key FileMaker DB Column Name 

kExportKeyHierarchicalKeywords hierarchical_keywords 

kExportKeyKeywords keywords 

kExportKeyMainRating main_rating 

kExportKeyProjectName project_name 

kExportKeyUniqueID unique_id 

 

 




